Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-27-2023, 06:59 PM   #1
Senior Member
 
Jim & Mary's Avatar
 
Join Date: Jul 2013
Posts: 721
Level up system

Due to a whole bunch of reasons, we've not been using our Redwood for awhile. The last time I powered it up, the display on the level controller is blank. The button for front gear up and down work ok, but to use the back 4 jacks, I think the display is necessary to get to the sub routine to control the back four legs. Does anyone know a quick and dirty way to get this display working without spending $350 on a replacement controller? Or how to raise the legs without using the display? Thanks, Jim
__________________


Jim & Mary 2013 36 RL with Titan Disc Brakes Residential Fridge Goodyear 17.5 H rated tires MORryde IS, MORryde pin box 2015 Ford F350 King Ranch DRW
Jim & Mary is offline   Reply With Quote
Old 06-03-2023, 04:33 PM   #2
Junior Member
 
Join Date: May 2016
Posts: 4
Quote:
Originally Posted by Jim & Mary View Post
Due to a whole bunch of reasons, we've not been using our Redwood for awhile. The last time I powered it up, the display on the level controller is blank. The button for front gear up and down work ok, but to use the back 4 jacks, I think the display is necessary to get to the sub routine to control the back four legs. Does anyone know a quick and dirty way to get this display working without spending $350 on a replacement controller? Or how to raise the legs without using the display? Thanks, Jim
When this happened to me, as long as you remember the button pushes, all functions worked without the display.

Here is the instructions for Manual Mode.
Attached Images
File Type: jpg IMG_1657.jpg (194.7 KB, 19 views)
__________________
Traveling RV Doctor
Shiggs68 is offline   Reply With Quote
Old 06-04-2023, 07:22 PM   #3
Junior Member
 
Join Date: Jul 2015
Posts: 8
I just had to unplug mine for a few seconds and plug it back in and it worked again
RuffinIt is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Redwood RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT +1. The time now is 12:38 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
×