Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-12-2015, 01:58 PM   #61
Senior Member
 
Shane Wood's Avatar
 
Join Date: Nov 2014
Posts: 1,988
Send a message via AIM to Shane Wood Send a message via MSN to Shane Wood Send a message via Yahoo to Shane Wood
found this little tidbit some of you may enjoyIMG_98210730790943.jpeg
__________________
2015 36RL pushing a 2015 Denali
Shane Wood is offline   Reply With Quote
Old 01-12-2015, 08:25 PM   #62
Member
 
Join Date: Dec 2013
Posts: 54
Wow! Didn't see that coming on this thread. Nice jab at us Ford folks.......
__________________

Bob & Debbie with Meeko & Lucy
2014 F350, SC, LB 4X4, 6.7
2014 31 SL
USN retired, 31 years
"If it was easy, anybody could do it"
CV67Cheng is offline   Reply With Quote
Old 01-12-2015, 10:30 PM   #63
Senior Member
 
atom ant's Avatar
 
Join Date: Feb 2013
Posts: 7,101
Ahhh - been there, done that

Minor setback - made up for lost time in brute power and acceleration!
Attached Images
File Type: jpg 07302006 Truck Tow 03.jpg (821.8 KB, 3 views)
__________________
Brad & Dory - Lone Tree, CO
CURRENT - 2013 Itasca Meridian 42E/2013 Wrangler 4dr Sahara
SOLD - 2014 Redwood 36RL/2014 F350 DRW
atom ant is offline   Reply With Quote
Old 01-12-2015, 10:33 PM   #64
Senior Member
 
Rick and Mindy's Avatar
 
Join Date: Feb 2013
Posts: 1,427
Been there done that too, only it was a Dodge!!
__________________
Rick and Mindy
Retired
2013 Redwood 31SL, 2011 Ford F350 SRW, 6.7, Crew Cab with Firestone Bags, Titan Disc Brakes
Rick and Mindy is offline   Reply With Quote
Old 01-12-2015, 10:37 PM   #65
Senior Member
 
atom ant's Avatar
 
Join Date: Feb 2013
Posts: 7,101
Mine was a direct result of Bradley driving too long and getting tired and filling the truck off the green handle pump, which at this gas station happened to be gasoline. Yellow is diesel at that place. Never even turned the key on, just called for a wrecker. Worse parts were, the truck was also bought on that trip and only had 1,800 miles on it, and the fuel I put in was premium
__________________
Brad & Dory - Lone Tree, CO
CURRENT - 2013 Itasca Meridian 42E/2013 Wrangler 4dr Sahara
SOLD - 2014 Redwood 36RL/2014 F350 DRW
atom ant is offline   Reply With Quote
Old 01-12-2015, 10:50 PM   #66
Senior Member
 
Shane Wood's Avatar
 
Join Date: Nov 2014
Posts: 1,988
Send a message via AIM to Shane Wood Send a message via MSN to Shane Wood Send a message via Yahoo to Shane Wood
DW just did the same to my truck last weekend. Lucky she didn't start it either. 200.00 to drain tank
__________________
2015 36RL pushing a 2015 Denali
Shane Wood is offline   Reply With Quote
Old 01-12-2015, 11:06 PM   #67
Senior Member
 
atom ant's Avatar
 
Join Date: Feb 2013
Posts: 7,101
Unfortunately for me Ford hit me for $700 to purge, re-filter and prime in addition to draining the tank, as a condition of keeping it in warranty
__________________
Brad & Dory - Lone Tree, CO
CURRENT - 2013 Itasca Meridian 42E/2013 Wrangler 4dr Sahara
SOLD - 2014 Redwood 36RL/2014 F350 DRW
atom ant is offline   Reply With Quote
Old 01-12-2015, 11:18 PM   #68
Senior Member
 
Shane Wood's Avatar
 
Join Date: Nov 2014
Posts: 1,988
Send a message via AIM to Shane Wood Send a message via MSN to Shane Wood Send a message via Yahoo to Shane Wood
Unfortunately those green pump handles on unleaded tanks have made a lot of money for the mechanics
__________________
2015 36RL pushing a 2015 Denali
Shane Wood is offline   Reply With Quote
Old 01-12-2015, 11:22 PM   #69
Site Team
 
Dave&Ginny's Avatar
 
Join Date: Jan 2012
Posts: 5,379
That's one reason why I like having 2 fuel tanks and I carry an extra fuel filter with me. I would just draw off the good tank until I got home.
__________________
SOB "The RV Wiseguy"
Dave&Ginny is offline   Reply With Quote
Old 01-12-2015, 11:36 PM   #70
Senior Member
 
Shane Wood's Avatar
 
Join Date: Nov 2014
Posts: 1,988
Send a message via AIM to Shane Wood Send a message via MSN to Shane Wood Send a message via Yahoo to Shane Wood
Works well as long as u remember which way to flip the switch for which tank
__________________
2015 36RL pushing a 2015 Denali
Shane Wood is offline   Reply With Quote
Old 01-12-2015, 11:46 PM   #71
Senior Member
 
Rick and Mindy's Avatar
 
Join Date: Feb 2013
Posts: 1,427
Quote:
Originally Posted by atom ant View Post
Unfortunately for me Ford hit me for $700 to purge, re-filter and prime in addition to draining the tank, as a condition of keeping it in warranty
OUCH!! Mine was a lift pump failure while traveling in the middle of Iowa headed to Minnesota. I was covered under warranty...........only one problem. It was when they were going thru bankruptcy and the replacement part wasn't available and was indefinitely on back order. The dealer was able to go to Cummins and get the original style pump and get us back on the road............$900.00 later. I was able to convince Chrysler to reimburse me for the part 4 months later. You gotta do what you gotta do when you are on the road.
__________________
Rick and Mindy
Retired
2013 Redwood 31SL, 2011 Ford F350 SRW, 6.7, Crew Cab with Firestone Bags, Titan Disc Brakes
Rick and Mindy is offline   Reply With Quote
Old 01-12-2015, 11:57 PM   #72
Site Team
 
Dave&Ginny's Avatar
 
Join Date: Jan 2012
Posts: 5,379
Quote:
Originally Posted by Shane Wood View Post
Works well as long as u remember which way to flip the switch for which tank

First you have to remember which pump to use and then you have to remember which tank to use.

At least the tanks are pretty easy to drain and the filters are easy to change. I'm more worried about water contamination.
__________________
SOB "The RV Wiseguy"
Dave&Ginny is offline   Reply With Quote
Old 01-12-2015, 11:59 PM   #73
Site Team
 
Dave&Ginny's Avatar
 
Join Date: Jan 2012
Posts: 5,379
Quote:
Originally Posted by Rick and Mindy View Post
OUCH!! Mine was a lift pump failure while traveling in the middle of Iowa headed to Minnesota. I was covered under warranty...........only one problem. It was when they were going thru bankruptcy and the replacement part wasn't available and was indefinitely on back order. The dealer was able to go to Cummins and get the original style pump and get us back on the road............$900.00 later. I was able to convince Chrysler to reimburse me for the part 4 months later. You gotta do what you gotta do when you are on the road.
They had some problems with those lift pumps. I've talked to several folks that fought that fight.
__________________
SOB "The RV Wiseguy"
Dave&Ginny is offline   Reply With Quote
Old 01-13-2015, 12:05 AM   #74
Senior Member
 
Shane Wood's Avatar
 
Join Date: Nov 2014
Posts: 1,988
Send a message via AIM to Shane Wood Send a message via MSN to Shane Wood Send a message via Yahoo to Shane Wood
Just goes to show you
I purchased a new place and it had rv parking c/w sewer dump 30 a and 50 a plugs
I parked my trailer next to the house and plugged in to the 30 a plug without checking it, assuming it was 120v
It was wired for 240volts
Next thing was new invertor,microwave and stereo
Got caught with the assume
__________________
2015 36RL pushing a 2015 Denali
Shane Wood is offline   Reply With Quote
Old 01-13-2015, 12:42 AM   #75
Senior Member
 
atom ant's Avatar
 
Join Date: Feb 2013
Posts: 7,101
Quote:
Originally Posted by Rick and Mindy View Post
OUCH!! Mine was a lift pump failure while traveling in the middle of Iowa headed to Minnesota. I was covered under warranty...........only one problem. It was when they were going thru bankruptcy and the replacement part wasn't available and was indefinitely on back order. The dealer was able to go to Cummins and get the original style pump and get us back on the road............$900.00 later. I was able to convince Chrysler to reimburse me for the part 4 months later. You gotta do what you gotta do when you are on the road.
Oh man, of all the rotten luck! Kind of makes you realize what all those loyal Carriage owners went through when they announced bankruptcy!
__________________
Brad & Dory - Lone Tree, CO
CURRENT - 2013 Itasca Meridian 42E/2013 Wrangler 4dr Sahara
SOLD - 2014 Redwood 36RL/2014 F350 DRW
atom ant is offline   Reply With Quote
Old 01-13-2015, 12:44 AM   #76
Senior Member
 
atom ant's Avatar
 
Join Date: Feb 2013
Posts: 7,101
Quote:
Originally Posted by Dave&Ginny View Post
First you have to remember which pump to use and then you have to remember which tank to use.
Ya I was failing on all accounts

Between the transmission going out on our 2001 on the way out, and me messing this one up on the way back, we spent more time camping under the Ford Sign than the KOA! My daughter still tells me I did all that because I was too cheap to pay for a campsite.
__________________
Brad & Dory - Lone Tree, CO
CURRENT - 2013 Itasca Meridian 42E/2013 Wrangler 4dr Sahara
SOLD - 2014 Redwood 36RL/2014 F350 DRW
atom ant is offline   Reply With Quote
Old 01-13-2015, 01:05 AM   #77
Senior Member
 
Rick and Mindy's Avatar
 
Join Date: Feb 2013
Posts: 1,427
Quote:
Originally Posted by Dave&Ginny View Post
They had some problems with those lift pumps. I've talked to several folks that fought that fight.
The fix was a kit that was to go in the fuel tank but there were only 2 of those in the entire state and the dealers would not cut loose of them. Funny thing about it was 2 years later, after Chrysler reimbursed me for the pump, the pump went out again. This time the warranty had expired. I contacted Chrysler in Michigan and told them that if the original pump had been replaced with the kit the first time I would not be in this mess again. They agreed and paid for the replacement of the second pump with the kit! It never hurts to squeal a little when you think you've been taken.
__________________
Rick and Mindy
Retired
2013 Redwood 31SL, 2011 Ford F350 SRW, 6.7, Crew Cab with Firestone Bags, Titan Disc Brakes
Rick and Mindy is offline   Reply With Quote
Old 01-13-2015, 02:08 AM   #78
Senior Member
 
atom ant's Avatar
 
Join Date: Feb 2013
Posts: 7,101
Quote:
Originally Posted by Shane Wood View Post
Just goes to show you
I purchased a new place and it had rv parking c/w sewer dump 30 a and 50 a plugs
I parked my trailer next to the house and plugged in to the 30 a plug without checking it, assuming it was 120v
It was wired for 240volts
Next thing was new invertor,microwave and stereo
Got caught with the assume
Ya, never trust the prior owner! They will get you everytime. I was removing some garage lights on a house I bought and he switched the neutral instead of hot. Sent me for a ride off the ladder.
__________________
Brad & Dory - Lone Tree, CO
CURRENT - 2013 Itasca Meridian 42E/2013 Wrangler 4dr Sahara
SOLD - 2014 Redwood 36RL/2014 F350 DRW
atom ant is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Redwood RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT +1. The time now is 08:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×