Reply
 
Thread Tools Display Modes
 
Old 08-07-2015, 05:58 AM   #1
Member
 
Join Date: Sep 2014
Posts: 60
Bedroom Slide Issue on 2014 Redwood 36RL

Issue after long stay at our summer holiday spot (Blackwell Island RV Park- Coeur D Alene ,ID), when we're hitching up to leave could not get slide in . After trying a number of times finally got it in. And then when we got to our next destination we could not get it open until e
We were hooked to shore power for a while ,then finally got it open all the way

Is this a battery issue,or something to do with the electric motors?
BobH is offline   Reply With Quote
Old 08-07-2015, 06:06 AM   #2
Senior Member
 
travelin' texans's Avatar
 
Join Date: Sep 2012
Posts: 2,388
Probably both, lube slide rails & motor with silicone lubricant & have batteries checked out or replaced.
__________________

Danny & Linda
Fulltimers since 2008
2013 Denali 3500 drw 4x4 d/a
2013 RW 36 FB black & tan
travelin' texans is offline   Reply With Quote
Old 08-07-2015, 06:08 AM   #3
Senior Member
 
Join Date: Feb 2015
Posts: 589
Did you try spaying with CRC. Slide has been known to stick and using the spray helps
__________________

2015 RL38
2008 Ford F450
RWJSIM2003 is offline   Reply With Quote
Old 08-07-2015, 07:33 AM   #4
Member
 
Join Date: Sep 2014
Posts: 60
Could it also be that maybe because we were plugged into shore power for 25 days that the batteries maybe became overcharged?
BobH is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT +1. The time now is 02:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.