Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-07-2020, 08:22 PM   #1
Member
 
Join Date: Sep 2014
Posts: 70
LCI Auto Level Control

Hi Everyone
Does anyone one know how the 2+5 year Warrany works with Redwood
I recently had an issue with my LCI Auto Level Control , where the screen went blank. Thought it was a fuse but after doing a lot of checking stumbled on the control still working just no LCD screen , so really donít know what mode your in for manual operation
Bob H
BobH is offline   Reply With Quote
Old 08-07-2020, 10:30 PM   #2
Senior Member
 
travelin' texans's Avatar
 
Join Date: Sep 2012
Posts: 3,039
The first thing I'd check is your batteries. Without a full 12+ volts the level up system will not operate.
You didn't state the year model of your RW, but if the batteries are 4-6 years old they are due for replacement.
Have you tried unplugging the display for about 10 seconds & plugging back in to reboot?
Sorry, forgot the original question, I have no clue about the 2+5 warranty!!
__________________
Danny & Linda
Former '13 FB owner
Currently rvless!
travelin' texans is offline   Reply With Quote
Old 08-07-2020, 10:55 PM   #3
Member
 
Join Date: Sep 2014
Posts: 70
Quote:
Originally Posted by travelin' texans View Post
The first thing I'd check is your batteries. Without a full 12+ volts the level up system will not operate.
You didn't state the year model of your RW, but if the batteries are 4-6 years old they are due for replacement.
Have you tried unplugging the display for about 10 seconds & plugging back in to reboot?
Sorry, forgot the original question, I have no clue about the 2+5 warranty!!
It works. Just donít see anything on screen. Screen lights up but itís blank!
BobH is offline   Reply With Quote
Old 08-08-2020, 01:36 AM   #4
Senior Member
 
mhs4771's Avatar
 
Join Date: Jan 2012
Posts: 2,516
Contact LCI's Customer Service, they have been very helpful walking others through problems.
__________________
Michelle & Ann
2018 Chevy 3500HD Crew Cab High Country DRW, D/A, 2016 RW39MB, Dual ACs, Auto Level, Auto Sat Dish, Stack W/D, King Sleep #, 17.5" Sailuns w/Disc, MORryde IS & Pin, Comfort Ride Hitch, 5.5 Onan, Res Fridge & Induction Cook Top
mhs4771 is offline   Reply With Quote
Old 08-08-2020, 04:46 PM   #5
Junior Member
 
Join Date: Mar 2015
Posts: 6
This happened a few years back to our 36FB. The touch screen went blank but all components worked.I simply removed Touch screen and unplugged it for several minutes.
This did the trick and has been working ever since.
larryg is offline   Reply With Quote
Old 08-08-2020, 10:18 PM   #6
Member
 
Join Date: Sep 2014
Posts: 70
Quote:
Originally Posted by larryg View Post
This happened a few years back to our 36FB. The touch screen went blank but all components worked.I simply removed Touch screen and unplugged it for several minutes.
This did the trick and has been working ever since.
Iíve tried this a couple of times but nothing. Maybe I nee to shut power off to everything completely like a total reset. I will give that a whirl
BobH
BobH is offline   Reply With Quote
Old 08-09-2020, 01:26 AM   #7
Member
 
Join Date: Mar 2020
Posts: 40
Have had to deal with LCI several times over the years, both on phone and email, they have been extremely helpful.
Wolfyukon is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Redwood RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT +1. The time now is 12:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×