Redwood RV Owners Community

Redwood RV Owners Community (http://www.redwoodowners.com/forums/)
-   General RV Questions (http://www.redwoodowners.com/forums/f10/)
-   -   sequoia brake issue (http://www.redwoodowners.com/forums/f10/sequoia-brake-issue-3063.html)

steve & darlene 06-25-2015 07:49 PM

sequoia brake issue
 
I purchased a new 39' Sequoya a few months ago, on our first (and only) trip, I discovered several things that needed to be repaired. The trailer was in the shop for several weeks to make the repairs, the most important repair was the brakes. They only engaged very little while braking the truck, and when I tested it using the truck switch only, it barely slowed down, even when I pushed the switch all the way to 10.
When I picked it up it was still doing the same thing. The repairman came out and adjusted the pad until it was tight to the drum, and it still would not work.
The shop said it was the truck switch and to take it back to be tested. I did and it came back as working properly.
My question is this: Has anyone else had this problem with the drum brake only working very little? If so what did you have to do to fix it ?
My wife and I do not want to take a chance on a trip with the brakes not working properly.
I feel as though I am getting the runaround from the dealer, but do not want to go postal if it might be something else.
Any help or advise will be appreciated.
Thank You

Steve Rees

atom ant 06-25-2015 09:51 PM

Steve,
Are you sure they are even working at all? Usually they work or they don't and almost 100% its a problem with the trailer wiring - cut wires in the hub usually.

Have someone pump the brakes and hold a compass next to each wheel. The compass north should jump to the wheel each time the brake is pressed, or the magnet is doing nothing.

PS - hopefully the shop backed off those brakes - if not make sure it is well documented so you can explain when the brakes are burnt.

PS2 - Your brakes may not lock up, but they should bring you to a stop without using the truck brakes from about 30 mph.

Shane Wood 06-25-2015 11:17 PM

Steve
There are a couple other things that it could be as well. The dealer not checking properly. A lot of these trailers have had problems with grease seals and grease getting on the shoes which leaves you with little braking if any. Also if you have a built in brake controller in your truck it may not be set to electric brakes. If you look at some of the people working in the rv dealerships they are lacking experienced people.
Like Brad said check to make sure you have power going to them and if so I would pull wheels and drums to check for grease

NW Snowbirds 06-25-2015 11:32 PM

Actually, Grease leaking into the brakes makes them stick. Try pulling the emergency brake switch on the hitch and then try to tow the trailer. It should be extremely difficult to move even if the wheels do not lock up. If it is not very difficult to move the trailer then you have an issue with the brakes on the trailer.

Shane Wood 06-25-2015 11:51 PM

Quote:

Originally Posted by atom ant (Post 49187)
Steve,
Are you sure they are even working at all? Usually they work or they don't and almost 100% its a problem with the trailer wiring - cut wires in the hub usually.

Have someone pump the brakes and hold a compass next to each wheel. The compass north should jump to the wheel each time the brake is pressed, or the magnet is doing nothing.

PS - hopefully the shop backed off those brakes - if not make sure it is well documented so you can explain when the brakes are burnt.


PS2 - Your brakes may not lock up, but they should bring you to a stop without using the truck brakes from about 30 mph.

Quote:

Originally Posted by NW Snowbirds (Post 49191)
Actually, Grease leaking into the brakes makes them stick. Try pulling the emergency brake switch on the hitch and then try to tow the trailer. It should be extremely difficult to move even if the wheels do not lock up. If it is not very difficult to move the trailer then you have an issue with the brakes on the trailer.

you are very correct about a brake locking up when grease is on it. When you drag a trailer 2600 miles with grease on the drum it eventually brakes down and what is left destroys your braking. I think these are coming out of the factory with leaking seals and depending how far they are hauled to the dealership is where the problem lies, compounded with the fact that thhe dealer not looking at them prior to delivery to the customer
:banghead:

steve & darlene 06-26-2015 02:34 AM

Quote:

Originally Posted by Shane Wood (Post 49193)
you are very correct about a brake locking up when grease is on it. When you drag a trailer 2600 miles with grease on the drum it eventually brakes down and what is left destroys your braking. I think these are coming out of the factory with leaking seals and depending how far they are hauled to the dealership is where the problem lies, compounded with the fact that thhe dealer not looking at them prior to delivery to the customer
:banghead:

Thank You all very much for taking the time to respond to my question. The MSRP was $97,000, and we paid very close to $60,000.
Way too much money to not being able to use it with confidence due to the brakes not properly working.
I will try the emergency switch first, and then try everything else you all have suggested.
Please keep responding with any other suggestions, for the brakes and everything else you can tell me. While I have had two other 5ers, I am still learning this Trailer. There are several items (options) that I have never used, and would like all the tips you are willing to post.
I AM NOT afraid to ask questions, or follow up with the new advise from more experienced campers.

Steve Rees

markw 06-26-2015 05:41 PM

I had the same problem, little to no braking. All four brakes covered with grease. By the time we returned from FL in April 13, the brakes were done. Not more than 4500 miles total.


Mark

travelin' texans 06-26-2015 05:50 PM

The crappy seals contaminating brakes have been an issue from the very beginning & I would suspect it still is in your situation. It honestly believe the only owners that haven't had this problem haven't checked or got disc brakes.

azandy 06-27-2015 12:54 PM

I will say our current fiver had seals leaking and three of four were fixed. I had zero brakes when I left the dealer. Brought it right back. They tightened the shoes and I now have a tiny bit only. Truck checked out fine. They couldn't figure it out and sent me on my way. Pretty much a waste of $500 in my eyes. I made it to an rv park near my job site in Louisiana where it still is right now.

I would check all your connections. Make sure a good ground. I'm certain my issue is a ground problem that I hope to find before I head home. I too am not a huge fan of 15000 pounds behind me with no brakes.


All times are GMT +1. The time now is 03:07 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.