Reply
 
Thread Tools Display Modes
 
Old 09-03-2016, 01:34 AM   #1
Member
 
Join Date: Jun 2015
Posts: 40
Brakes don't work

Spending the night at camp morryde. Left it here after the rally for upgrades. Had the disc brakes put on, was having the titan pump also, but was told that it wouldn't fit so I've got the one they normally use, anyway I've got a 2015 GMC with the factory brake controller. . Pull the break away and brakes lock up, manually apply and the pump runs. Press on the brake and nothing. Called back to my dealership but no help. I've heard that 2014 and earlier had issues, but mine is a late 2015. Staff here didn't have any ideas other than must be the truck?
Moland is offline   Reply With Quote
Old 09-03-2016, 02:01 AM   #2
Senior Member
 
Shane Wood's Avatar
 
Join Date: Nov 2014
Posts: 1,931
Send a message via AIM to Shane Wood Send a message via MSN to Shane Wood Send a message via Yahoo to Shane Wood
I had the same problem when I installed my discs.
Pull the breakaway and the pump would engage step on the brake and nothing. Take it to an empty parking lot and try it. With the Progressive breaking system on the 2015 and up you will not notice anything unless the vehicle is moving. Also the integrated controllers on the new ones do not have the same voltage output on any given vehicle. I run my controller at 7 a buddy has to run his at 9. At low speeds it almost seems like you have no trailer brakes until you stomp the brake pedal. With these new controllers the vehicle needs to be in motion for them to work
__________________
2015 36RL pushing a 2015 Denali
Shane Wood is offline   Reply With Quote
Old 09-03-2016, 02:10 AM   #3
Senior Member
 
Rick and Mindy's Avatar
 
Join Date: Feb 2013
Posts: 1,382
I think Ted 95 had the same issue with his new GMC Denali. Maybe Wayne will see this and give some input. He told me that he had to be moving before the brakes would work.
__________________
Rick and Mindy
Retired
2013 Redwood 31SL, 2011 Ford F350 SRW, 6.7, Crew Cab with Firestone Bags, Titan Disc Brakes
Rick and Mindy is offline   Reply With Quote
Old 09-03-2016, 02:14 AM   #4
Senior Member
 
Retired educators's Avatar
 
Join Date: Sep 2012
Posts: 178
Quote:
Originally Posted by Moland View Post
Spending the night at camp morryde. Left it here after the rally for upgrades. Had the disc brakes put on, was having the titan pump also, but was told that it wouldn't fit so I've got the one they normally use, anyway I've got a 2015 GMC with the factory brake controller. . Pull the break away and brakes lock up, manually apply and the pump runs. Press on the brake and nothing. Called back to my dealership but no help. I've heard that 2014 and earlier had issues, but mine is a late 2015. Staff here didn't have any ideas other than must be the truck?
Have them take a look at the cam module that is on the RV. I have a 2015 Denali and my brakes would not work until the cam module on RV was changed. Has to do with the voltage.
__________________
2016 38 RL, tan and burgundy, H rated tires on 17.5 rims, disc brakes, washer and dryer, residential refrigerator, MorRyde IS, 2015 GMC 3500 HD Denali,Duramax DRW, 4x4, Firestone air bags
Retired educators is offline   Reply With Quote
Old 09-04-2016, 02:02 AM   #5
Member
 
Join Date: Jun 2015
Posts: 40
Should of put it in tow/haul mode then I could of seen what the brake pedal was sending. You folks right on the money, once moving I had brakes. I called Gary this morning at MORRYDE and he was relieved and would pass on about the truck needs to be moving. Thanks
Moland is offline   Reply With Quote
Old 09-04-2016, 02:25 AM   #6
Senior Member
 
Shane Wood's Avatar
 
Join Date: Nov 2014
Posts: 1,931
Send a message via AIM to Shane Wood Send a message via MSN to Shane Wood Send a message via Yahoo to Shane Wood
Moland
When towing always keep in tow haul. It changes the transmission shift pattern for the additional weight you are carrying
__________________
2015 36RL pushing a 2015 Denali
Shane Wood is offline   Reply With Quote
Old 09-05-2016, 01:57 AM   #7
Senior Member
 
Join Date: Jan 2016
Posts: 299
I have a 2016 Denali 3500. The truck has to be moving 3-4 mph. There is a sensor in the GM. The reason for this is when you are at a light the pump in not pumping for nothing. When the Titan system was installed we did all the testing (not moving)and all was great. But when we hit the pedal nothing- zero- sba -0 - etc. They then added a special item and still nothing.
I was freaking as I did not want an external brake controller. I wanted my truck to run properly. Well we finally got Ron on the phone and that is when we removed the gismo and all is working 110%. I mean without the upgrade I did we would have taken out a young girl who went through a red light on the way home from the rally. You should be ok...good luck....
__________________
Meet Teddy Bear
Make Every Day Count
2016 Denali 3500 Diesel SRW
2015 38 GK
Cheryl & Wayne
ted 95 is offline   Reply With Quote
Old 09-16-2016, 05:56 PM   #8
Member
 
hobie16's Avatar
 
Join Date: Oct 2015
Posts: 34
No braking when stopped?

"The truck has to be moving 3-4 mph. There is a sensor in the GM. The reason for this is when you are at a light the pump in not pumping for nothing..."

So does that mean that there is no trailer braking when not in motion? I think I would want to have trailer brakes for holding on a grades, not just the tow vehicle.

I am having Ron install the conversion this December while in Texas.
__________________
2015 sequoia 38HRL
2005 F250 King Ranch Crew Cab, 4x4, V10, 4.10 gears (150K and counting)
hobie16 is offline   Reply With Quote
Old 09-17-2016, 05:12 AM   #9
Senior Member
 
Join Date: Jan 2016
Posts: 299
From what I was told.... When you come to a complete stop the pump stops pumping for no reason. But the pressure that was used to stop the coach is still in the system till you let go of the brake pedal. So yes when you are sitting there at a light all brakes have pressure on them as long as you were moving so the sensor enabled the pump to kick in. But why don't you call Ron and speak to him about your concerns. I must have called him 10 times prior to having the work done. And keep in mind my axles and drums were just changed out for 8k set ups. So they were double the size of the 7k and only had 40 miles on them. Kind of a shame to have scrapped new shoes and drums. But I'm 101% happy with the set up.
__________________
Meet Teddy Bear
Make Every Day Count
2016 Denali 3500 Diesel SRW
2015 38 GK
Cheryl & Wayne
ted 95 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Redwood RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT +1. The time now is 02:49 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.