Reply
 
Thread Tools Display Modes
 
Old 07-25-2014, 10:37 PM   #1
Senior Member
 
Adamsvr's Avatar
 
Join Date: Jan 2012
Posts: 596
Water pump is air locked

Anyone know how to get water back to the water pump? I can hear it running when turned on, but no water flows to the faucets. TIA, Vic
__________________
2012 Redwood RL with Slide-in-the Slide; 2011 F450; Onan 5.5 Gen; G614 Wheels
Adamsvr is offline   Reply With Quote
Old 07-25-2014, 10:53 PM   #2
Senior Member
 
Join Date: Feb 2014
Posts: 545
Vic, If you're sure you have water in the fresh water tank, you might have a bad impeller. The pump on my rig is easy to get to, just behind the wall next to the convenience center.

There is also a sediment bowl that could be plugged on the input side of the pump.

Ken
brenkco is offline   Reply With Quote
Old 07-25-2014, 11:25 PM   #3
Senior Member
 
Adamsvr's Avatar
 
Join Date: Jan 2012
Posts: 596
Thanks Ken! Will pull the wall and check it out tomorrow. Vic
__________________
2012 Redwood RL with Slide-in-the Slide; 2011 F450; Onan 5.5 Gen; G614 Wheels
Adamsvr is offline   Reply With Quote
Old 07-25-2014, 11:38 PM   #4
Senior Member
 
Radio_Flyer's Avatar
 
Join Date: Sep 2012
Posts: 448
Check your valve as well. There is a valve in the compartment, hard to see but straight down whe you open the cubby to where the filter is.
__________________
Skip & Patty
2013 Redwood 36RL
2015 Ram 3500 Laramie CC DRW 4x4 (Bertha)
USN Retired

Radio_Flyer is offline   Reply With Quote
Old 07-26-2014, 12:01 AM   #5
Senior Member
 
atom ant's Avatar
 
Join Date: Feb 2013
Posts: 7,101
Sometimes I have to open something to vent before it will prime. It doesn't like deadheading with air.
__________________
Brad & Dory - Lone Tree, CO
CURRENT - 2013 Itasca Meridian 42E/2013 Wrangler 4dr Sahara
SOLD - 2014 Redwood 36RL/2014 F350 DRW
atom ant is offline   Reply With Quote
Old 07-26-2014, 04:03 AM   #6
lwg
Senior Member
 
lwg's Avatar
 
Join Date: Jun 2013
Posts: 918
Quote:
Originally Posted by atom ant View Post
Sometimes I have to open something to vent before it will prime. It doesn't like deadheading with air.
Yes, try this first and let it run for about 60 seconds.
__________________
2014 Redwood 38BR, Fulltiming
2013 Ford F-350 CCSB 6.7L 4x4 SRW, B&W Companion Hitch, Air Bags
lwg is offline   Reply With Quote
Old 07-26-2014, 04:43 AM   #7
Senior Member
 
Join Date: May 2013
Posts: 467
There could also be a leak before the pump. Make sure they didn't put a screw in your winterizing line like mine.

Mark
__________________
2013 36RE, 2008 GMC 3500CC DRW
markw is offline   Reply With Quote
Old 07-26-2014, 01:37 PM   #8
Senior Member
 
Join Date: Mar 2012
Posts: 555
If this is the first time you have used your tank water is a while there may be algae embedded in the filter screen. This will stop your flow. Again check that valve right in front of the pump. Could be hard to turn at first. Good luck.
__________________
Jay and Linda
2013 36RL
Tobys Home is offline   Reply With Quote
Old 07-26-2014, 04:02 PM   #9
Traveling
 
Join Date: Mar 2014
Posts: 910
It's worth noting that we noticed a major improvement in our other RV water pump after sanitizing. The buildup of slime in there with normal use causes a big loss of efficiency and also can cause it to run intermittently for no reason. Very annoying. 1/4 cup of bleach in the tank (dilute in a gallon of water first, do not add full strength) and then fill tank, let set a few hours, then drain. Rinse. MUCH better, and much safer. I was surprised at the difference.
TNTBaker is offline   Reply With Quote
Old 07-26-2014, 04:50 PM   #10
Site Team
 
Dave&Ginny's Avatar
 
Join Date: Jan 2012
Posts: 5,379
Check you cap on the line they use for winterizing the unit. They had lost the rubber washer on mine and it acted the same way. VERY frustrating....to make sure this didn't happen again, I put a pex shut off on that line.
__________________
SOB "The RV Wiseguy"
Dave&Ginny is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Redwood RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT +1. The time now is 08:36 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×