Reply
 
Thread Tools Display Modes
 
Old 09-23-2014, 10:32 PM   #1
Senior Member
 
Oriana's Avatar
 
Join Date: Dec 2012
Posts: 1,257
Level-Up System Issue

Levelling System Issue

This morning while hooking up I experienced an issue with the Level-Up system. The rear jacks all retracted OK with manual operation, then went to raise the front of the coach. Pumps sounds were normal, but the coach wasn't going up. Finally found the driver's side middle leg was going down, followed by driver's side rear leg going down.

Tried all valves with an Allen Key to ensure they were closed, noting that when I opened the one for the front legs the front of the coach dropped. This didn't happen the time I had to operate the front legs with the drill.

Turned the power to the controller off/on a few times to try a reset, but no change. Eventually figured that by going to manual and raising the front, I had to wait for the 2 rear driver side legs to ground, then the front came up. Had to raise it an inch, then raise the rear legs, then repeat the process.

On arrival, it wouldn't auto level, had to try various operations in manual to get it level.

The slides operated normally.

Any ideas??
__________________

Andy & Judi, Canine Companions Duke & Kona
2012 F350 Lariat CC SRW Airlift 5000 |2013 RW 36FL Winegard Trav'ler
Travel Blog: www.andyandjudi.com
Oriana is offline   Reply With Quote
Old 09-23-2014, 11:58 PM   #2
Site Team
 
Dave&Ginny's Avatar
 
Join Date: Jan 2012
Posts: 5,379
I'm scratching my head on this one.....I wish I had some ideas to pass to you...sorry
__________________
SOB "The RV Wiseguy"
Dave&Ginny is offline   Reply With Quote
Old 09-24-2014, 12:32 AM   #3
Site Team
 
hoosierguy's Avatar
 
Join Date: Nov 2011
Posts: 1,282
Quote:
Originally Posted by Oriana View Post
Levelling System Issue

This morning while hooking up I experienced an issue with the Level-Up system. The rear jacks all retracted OK with manual operation, then went to raise the front of the coach. Pumps sounds were normal, but the coach wasn't going up. Finally found the driver's side middle leg was going down, followed by driver's side rear leg going down.

Tried all valves with an Allen Key to ensure they were closed, noting that when I opened the one for the front legs the front of the coach dropped. This didn't happen the time I had to operate the front legs with the drill.

Turned the power to the controller off/on a few times to try a reset, but no change. Eventually figured that by going to manual and raising the front, I had to wait for the 2 rear driver side legs to ground, then the front came up. Had to raise it an inch, then raise the rear legs, then repeat the process.

On arrival, it wouldn't auto level, had to try various operations in manual to get it level.

The slides operated normally.

Any ideas??

Andy,

Since the slides operate normally, I think your issue is limited to the Level-Up controller and/or cabling. This is just a guess, but, I would suggest carefully disconnecting the multi-wire connector on the back side of the main controller. Observe all of the connector pins to make sure they are fully seated in the connector housing. Also, make sure there are no broken wires to the pins. Then try operating the controller again to see if anything has changed about its operation.

I you don't see any better operation, the next part of the investigation is a little more difficult. You need to make the same observations about the connector on the leveling sensor that is on the other end of the cable. The sensor is somewhat difficult for us bigger fellows to get to because it is mounted on the ceiling up inside above the generator compartment. You have to squeeze in through the battery compartment to get to it. You will see it mounted on ceiling. There is a similar connector on the sensor box and these types of connectors on electronic assemblies tend to be a weak link.

Good luck on your investigation. I hope this helps.

Guy
__________________
Guy & Phyllis
2012 RW36RL,DualA/C,KodiakDiskBrakes,TrailAir Tri-Glide,GY_G614's,Mor/RydeSRE4000,HDShackles/WetBolts
2011Dodge3500Laramie,CrewCab,4x4,SRW,Michelins, LongBed,6.7LCTD,3.73,PullRiteSuper5th20.5KHitch, BlueOxBedsaver

hoosierguy is offline   Reply With Quote
Old 09-24-2014, 01:08 PM   #4
Senior Member
 
johnboytoo's Avatar
 
Join Date: Jul 2013
Posts: 2,054
^^^ what he said and what I typed on the other forum
__________________
Ours: '11 Monaco Diplomat 43DFT followed closely by '14 Jeep 4 dr Wrangler.
Hers: '13 Explorer Sport - AWD 365hp twin turbo scooter!
Previous: '13 Ford F350 CC Platinum and '13 38GK
johnboytoo is offline   Reply With Quote
Old 09-30-2014, 03:30 PM   #5
Member
 
Join Date: Jan 2014
Posts: 56
what he said and what I typed on the other forum??? is the other forum gone?? off line??? my bookmark for it just leads me back to this forum again...
mesg is offline   Reply With Quote
Old 09-30-2014, 04:06 PM   #6
Member
 
Join Date: May 2013
Posts: 32
Quote:
Originally Posted by mesg View Post
what he said and what I typed on the other forum??? is the other forum gone?? off line??? my bookmark for it just leads me back to this forum again...
I just got off the other forum...... things seem to be fine with it.

Doug.
__________________
2014 36RL, 2008 Dodge Dually
collindo is offline   Reply With Quote
Old 09-30-2014, 04:50 PM   #7
Senior Member
 
johnboytoo's Avatar
 
Join Date: Jul 2013
Posts: 2,054
Agree with Doug, it's fine --> http://www.redwoodrvowners .com/redwood/yabb2/YaBB.pl
__________________
Ours: '11 Monaco Diplomat 43DFT followed closely by '14 Jeep 4 dr Wrangler.
Hers: '13 Explorer Sport - AWD 365hp twin turbo scooter!
Previous: '13 Ford F350 CC Platinum and '13 38GK
johnboytoo is offline   Reply With Quote
Old 09-30-2014, 05:48 PM   #8
Senior Member
 
Oriana's Avatar
 
Join Date: Dec 2012
Posts: 1,257
Affirmative, no issues with the other forum. Working normally, with usual number of posts and new applicants.
__________________

Andy & Judi, Canine Companions Duke & Kona
2012 F350 Lariat CC SRW Airlift 5000 |2013 RW 36FL Winegard Trav'ler
Travel Blog: www.andyandjudi.com
Oriana is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Redwood RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT +1. The time now is 02:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×