Reply
 
Thread Tools Display Modes
 
Old 08-11-2016, 04:47 PM   #1
Junior Member
 
Join Date: Nov 2015
Posts: 19
High Elevation & Dual CO/Propage Monitor

In April the CO monitor was replaced in my 2013 RW with Camping World Safe-T-Alert 35. This last weekend, camping at 9,300 feet both times the gas heater fired up, so did the alarm a minute or two later. Shutting off the heater, opening all the windows, powered vents and door took several minutes before the alarm stopped. Fanning the monitor didn't seem to help.

Home at 3200 feet, everything is normal. Was the problem elevation and the thin oxygen?

Howard
__________________
Howard & Patti

2013 Redwood 36 FB adopted Nov 2015
2015 GMC 2500 Denali Crew Cab
Cocka-Poos - P.T. (Phineas Taylor) & Baylee
hmdarwin is offline   Reply With Quote
Old 08-11-2016, 04:55 PM   #2
Senior Member
 
atom ant's Avatar
 
Join Date: Feb 2013
Posts: 7,057
I don't think so, or you would hear about it more.
__________________
Brad & Dory - Lone Tree, CO
CURRENT - 2013 Itasca Meridian 42E/2013 Wrangler 4dr Sahara
SOLD - 2014 Redwood 36RL/2014 F350 DRW
atom ant is offline   Reply With Quote
Old 08-11-2016, 05:34 PM   #3
Senior Member
 
Join Date: Feb 2013
Posts: 1,854
Were you using a generator? Depending upon wind conditions and length of exhaust/tail pipe, fumes can settle under the coach and will creep inside.
__________________
2012 F350 KR CC DRW w/ some stuff
2013 36FL
Cindy and Tom, Toby and Kasey (our Berner and Newfie)
Oh...I forgot the five kids.
spindrift is offline   Reply With Quote
Old 08-11-2016, 07:53 PM   #4
Junior Member
 
Join Date: Nov 2015
Posts: 19
Thanks for your comments. No, we were not running the genny but I did think to look up the instruction sheet on the internet and I believe found my answer.

MALFUNCTION/SERVICE SIGNAL If any malfunction is detected, the
Gas LED will remain off and the Operational/CO LED will alternate
Red/Green and the alarm will sound once every 15 seconds. Press the
Test/Mute button. If the Test/Mute button does not clear the signals, check
the battery voltage. If the battery voltage is not low and the unit will not
return to normal operation, immediately remove the alarm and return
for service or warranty replacement.

The Mute button didn't work! I'll contact the company.

Thanks all,

Howard
__________________
Howard & Patti

2013 Redwood 36 FB adopted Nov 2015
2015 GMC 2500 Denali Crew Cab
Cocka-Poos - P.T. (Phineas Taylor) & Baylee
hmdarwin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Redwood RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT +1. The time now is 01:36 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.