Reply
 
Thread Tools Display Modes
 
Old 04-12-2013, 08:37 PM   #1
Senior Member
 
Buddy's Avatar
 
Join Date: Dec 2012
Posts: 514
I waxed both sides of all three slide today and the paste wax took the black marks off where the rubber seal had stuck. It actually just wiped right off. I also used Protect All Rubber Seal Treatment on all the seals except the top, I could not get to them with the toppers. I also used protect All Slide Out Dry Lube on the tracks on the bedroom slide and rails on the other two slides, I ran them in several time and they glide now. The wax helped as well I'm sure. Now I can't move, but it's done.
__________________
2012 Ford F450 Lariat FX4 dually, 2013 Redwood 36FB Red and Black Painted
Buddy is offline   Reply With Quote
Old 04-12-2013, 11:17 PM   #2
Senior Member
 
Adamsvr's Avatar
 
Join Date: Jan 2012
Posts: 596
I don't quite understand; however, if your slides don't move it probably involves the hydraulics. Check the 10amp fuse in the battery compartment. On the wiring on the right hand side about 1/2 way up in the back of the wiring harness you should be able to feel it. Check it out. Good luck.
Adamsvr is offline   Reply With Quote
Old 04-13-2013, 03:36 AM   #3
Senior Member
 
Buddy's Avatar
 
Join Date: Dec 2012
Posts: 514
No problems, just did maintenance to keep everything working properly.
__________________
2012 Ford F450 Lariat FX4 dually, 2013 Redwood 36FB Red and Black Painted
Buddy is offline   Reply With Quote
Old 04-14-2013, 10:10 AM   #4
Senior Member
 
Buddy's Avatar
 
Join Date: Dec 2012
Posts: 514


Go figure cheap, easy and it works.
__________________
2012 Ford F450 Lariat FX4 dually, 2013 Redwood 36FB Red and Black Painted
Buddy is offline   Reply With Quote
Old 04-14-2013, 02:30 PM   #5
Site Team
 
hoosierguy's Avatar
 
Join Date: Nov 2011
Posts: 1,285
Quote:
Originally Posted by Buddy
__________________
Guy & Phyllis
2012 RW36RL,DualA/C,KodiakDiskBrakes,TrailAir Tri-Glide,GY_G614's,Mor/RydeSRE4000,HDShackles/WetBolts
2011Dodge3500Laramie,CrewCab,4x4,SRW,Michelins, LongBed,6.7LCTD,3.73,PullRiteSuper5th20.5KHitch, BlueOxBedsaver

hoosierguy is offline   Reply With Quote
Old 04-15-2013, 07:31 AM   #6
Senior Member
 
Buddy's Avatar
 
Join Date: Dec 2012
Posts: 514
I noticed my toppers must be working with the rain and dirt, they were clean on top of the slides.
__________________
2012 Ford F450 Lariat FX4 dually, 2013 Redwood 36FB Red and Black Painted
Buddy is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Redwood RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT +1. The time now is 09:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×