Reply
 
Thread Tools Display Modes
 
Old 10-07-2018, 10:28 PM   #1
Senior Member
 
Char & Steve's Avatar
 
Join Date: Nov 2014
Posts: 982
Hepvo Vent

Has anyone had trouble with the Hepvo vent/trap. Think I have two, shower and kitchen sink.
I am getting a sewer smell when we use the shower or dump the grey tanks. Can't seem to pinpoint it. Have no other leaks that I can find so I am thinking it could be one of those. I replaced the in-line vent under the vanity but didn't help.

Steve
__________________

2014 Redwood 36FL and 2015 GMC Denali 3500 DW Duramax
Char & Steve is offline   Reply With Quote
Old 10-08-2018, 02:38 AM   #2
Senior Member
 
mhs4771's Avatar
 
Join Date: Jan 2012
Posts: 2,228
You should have at least three of them, kitchen sink/dish washer, shower, and bathroom sink/sinks. Don't know on the washer if it might have one or depend on the one down stream. If you can get access to them, they're easy to remove and check in the internal sleeve hasn't been torn or damaged in some way.
__________________
Michelle & Ann
2018 Chevy 3500HD Crew Cab High Country DRW, D/A, 2016 RW39MB, Dual ACs, Auto Level, Auto Sat Dish, Stack W/D, King Sleep #, 17.5" GY114s w/Disc, MORryde IS & Pin, Comfort Ride Hitch, 5.5 Onan, Res Fridge & Induction Cook Top
mhs4771 is offline   Reply With Quote
Old 10-08-2018, 07:44 PM   #3
Senior Member
 
Char & Steve's Avatar
 
Join Date: Nov 2014
Posts: 982
Thank You!! I will take a look.

Steve
__________________

2014 Redwood 36FL and 2015 GMC Denali 3500 DW Duramax
Char & Steve is offline   Reply With Quote
Old 10-13-2018, 08:34 PM   #4
Junior Member
 
Join Date: Sep 2018
Posts: 4
you might want to look under the bed..I have had a common hose between the tanks come off under there and when it does you get a very strong sewer smell in unit!! took awhile to find that one... look on left side towards head of the bed..
watts888 is offline   Reply With Quote
Old 10-13-2018, 11:46 PM   #5
Senior Member
 
Char & Steve's Avatar
 
Join Date: Nov 2014
Posts: 982
Thanks for all the info. Have had the bed apart and don't thing there is anything under it but will check again. We do have the Front Living model.

Steve
__________________

2014 Redwood 36FL and 2015 GMC Denali 3500 DW Duramax
Char & Steve is offline   Reply With Quote
Old 10-15-2018, 07:06 PM   #6
Junior Member
 
Join Date: Mar 2015
Posts: 2
I just pulled the one under my sink - was getting a strong sewer odor - cleaned and reinstalled it and fixed the problem. Just had gunk built up in the rubber sleeve which would not let it seal.
petenorwood is offline   Reply With Quote
Old 10-16-2018, 03:16 AM   #7
Junior Member
 
Join Date: Sep 2015
Posts: 12
Had the same problem initially with RV. Found that the one for the shower for some reason had the rubber sleeve push backwards into the valve. May be due to a install error. Just needed to push the rubber sleeve in the correct direction. Once I corrected this have not had a problem.
Note for horizontal installations there is a "up" position for the valve.
__________________
Geff & Sandy
deepunderh2o is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Redwood RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT +1. The time now is 05:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.