Reply
 
Thread Tools Display Modes
 
Old 10-14-2016, 04:25 AM   #1
Junior Member
 
Join Date: Sep 2014
Posts: 27
Furnace won't come on

Thermostat up and furnace should kick on but nothing ... Switched fan from auto to on and nothing ! Any ideas for issue or troubleshooting would be greatly appreciated
Steve & Kim is offline   Reply With Quote
Old 10-14-2016, 05:15 AM   #2
Senior Member
 
Join Date: Aug 2015
Posts: 390
1. Did it ever work?
2. Check your breakers, if the fan won't come on, could be power
3. Do you have both gas and electric heat on the thermostat? (Heat Pump)
4. Gas Turned on?

If you can't turn on the fan, then I would search for an electrical problem.
__________________
Scott
2015 38GK, Titan Brakes, H 114 Tires, IS
2015 Denali Dually
bergeman is offline   Reply With Quote
Old 10-14-2016, 12:32 PM   #3
Senior Member
 
johnboytoo's Avatar
 
Join Date: Jul 2013
Posts: 2,054
On ours, there used to be a delay once you turn it on... time for propane to flow, time for sensors to indicate heating, etc....

but like Scott said - check breakers - fuses... even if a breaker LOOKS ok, turn them off and back on to make sure !

Sounds like electrical, but to be certain it's not propane,
I would light the cooktop to ensure the gas is flowing and most of the air is out of the system.
(purging the system sometimes took a while for our 38gk, I would light a little bbq starter and hold it by the burner until it started rather than keep clicking the cooktop starter)
Once cooktop does ok, try heater again...

Do you have heat pumps on the roof ac ? do they work? if so, can use them until you resolve furnace issue...

That thermostat has SO many settings, just make sure it is set properly... good luck
__________________
Ours: '11 Monaco Diplomat 43DFT followed closely by '14 Jeep 4 dr Wrangler.
Hers: '13 Explorer Sport - AWD 365hp twin turbo scooter!
Previous: '13 Ford F350 CC Platinum and '13 38GK
johnboytoo is offline   Reply With Quote
Old 10-14-2016, 04:43 PM   #4
Senior Member
 
travelin' texans's Avatar
 
Join Date: Sep 2012
Posts: 2,868
If nothing on the furnace runs it's most likely coach battery related. Do your overhead lights or any other 12 volt items work?
__________________
Danny & Linda
Former '13 FB owner
Currently rvless!
travelin' texans is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Redwood RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT +1. The time now is 09:42 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.